Введение

  • В начало
  • Вперёд »

DBAScript128 DBAScript for Oracle – это инструмент администратора базы данных Oracle предназначенный для создания первичных объектов, а так же модификации структуры базы данных в соответствии со скриптами предоставляемыми разработчиками приложений. Простой и удобный графический интерфейс позволяет быстро подключаться к базам данных Oracle, загружать файл скрипта в многофункциональный редактор SQL, просматривать результаты выполнения скрипта и выполнять другие операции необходимые для работы с базой данных Oracle.

Главной особенностью программы является предварительный разбор скрипта, что позволяет видеть все команды и модифицируемые объекты до его выполнения. Дополнительные встроенные команды DBScript и некоторые эмулированные команды SQLPlus расширяют возможности применения скриптов. Существующая возможность перекомпиляции объектов базы данных, которые приобретают инвалидный статус, позволяет быстро восстановить нормальное состояние зависимых объектов.

Основные возможности:

· Выполнение SQL команд, PL/SQL блоков и некоторых команд SqlPlus по отдельности или в виде скрипта.
· Предварительный просмотр списка всех команд в скрипте.
· Быстрое повторное соединение с базой данных.
· Поддержка некоторых команд SqlPlus.
· Внутренние команды DBAScript.
· Перекомпиляция инвалидных объектов в ручном и автоматическом режимах.
· Ведение журнала выполняемых команд скрипта в трёх форматах.
· Резервное копирование PL/SQL объектов перед их изменением.

Информация по продукту:

· Домашняя страница: http://www.dba.ucoz.ru/


Системные требования

  • « Назад

Системные требования для DBAScript for Oracle:

· 300 Mhz Pentium-II-совместимый или более мощный процессор (рекомендуется 600 Mhz или выше)
· Microsoft Windows 98, Microsoft Windows NT4 c SP4 или более поздней версией, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows Vista
· 64 MB RAM (рекомендуется 128 MB или более)
· 10MB свободного пространства на жестком диске для установки программы
· Видео-карта Super VGA и монитор с минимальным разрешением 800x600 (рекомендуется Super VGA с разрешением 1024x768 или выше)
· Совместимая c Windows мышь
· Клиент для Oracle Database 8.0.6 или выше
· Возможность соединения с локальным или удаленным сервером Oracle


Регистрация

Вы можете стать зарегистрированным пользователем DBAScript for Oracle следующими способами:

· Воспользовавшись формой заказа на сайте dba.ucoz.ru

· Отправив письмо на почтовый ящик zhilin71@mail.ru. В письме укажите регистрируемый продукт и желаемое имя для регистрации. Это имя будет отображаться в окне “О программе”.

После оформления заказа вы получите письмо с инструкцией по оплате регистрируемого продукта. Для оплаты, вам необходимо, используя WebMoney, перевести 150 WMR на кошелек R143587181878 или 5 WMZ на кошелек Z353406844113 (в примечании к переводу, пожалуйста, укажите "регистрация DBAScript for Oracle"). Если у вас нет кошелька WebMoney, то вы можете легко завести его, а затем пополнить почтовым/банковским переводом или другими методами, описанными на сайте WebMoney.

Оплатив программный продукт, вы получите письмо, содержащее ключ, который необходимо ввести, выбрав пункт «Регистрация» в главном меню.

Ключ действителен только в пределах одной главной версии релиза DBAScript for Oracle. Например, покупая ключ для DBAScript версии 3.0.0, регистрация будет действительна только для всех версий, начинающихся с цифры 3. Для релизов, начинающихся с цифры 4, ключ уже будет недействителен.


Лицензионное соглашение

Лицензионное соглашение на использование УСЛОВНО-БЕСПЛАТНОЙ версии ПО

© 2007-2010 Жилин С.В. Все права защищены.

ВАЖНО: ПЕРЕД ИСПОЛЬЗОВАНИЕМ ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ ВНИМАТЕЛЬНО ПРОЧИТАЙТЕ ДАННОЕ СОГЛАШЕНИЕ.

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ КОНЕЧНОГО ПОЛЬЗОВАТЕЛЯ.

Автор программы (далее "АВТОР") предоставляет пользователю («ПОЛЬЗОВАТЕЛЬ») копию данного программного продукта (далее «ПО», «ПРОГРАММА») и предоставляет ПОЛЬЗОВАТЕЛЮ лицензию на использование данного ПО. Настоящее ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ (далее «ЛИЦЕНЗИЯ», «СОГЛАШЕНИЕ») определяет действия, которые ПОЛЬЗОВАТЕЛЬ вправе совершать по отношению к ПО, и включает перечень ограничений гарантий и ответственности. АВТОР может в любое время без предупреждения аннулировать ЛИЦЕНЗИЮ в случае нарушения ПОЛЬЗОВАТЕЛЕМ условий данной ЛИЦЕНЗИИ.

ЛИЦЕНЗИЯ НА НЕЗАРЕГИСТРИРОВАННУЮ КОПИЮ

Незарегистрированная копия ПО (далее «НЕЗАРЕГИСТРИРОВАННОЕ ПО») может использоваться ПОЛЬЗОВАТЕЛЕМ для ознакомительных целей в течение неопределённого периода после первоначальной установки НЕЗАРЕГИСТРИРОВАННОГО ПО. НЕЗАРЕГИСТРИРОВАННОЕ ПО разрешается свободно копировать и передавать другим пользователям для ознакомления.

ЛИЦЕНЗИЯ НА ЗАРЕГИСТРИРОВАННУЮ ПРОГРАММУ

Зарегистрированная копия ПРОГРАММЫ (далее «ЗАРЕГИСТРИРОВАННАЯ КОПИЯ») разрешает ПОЛЬЗОВАТЕЛЮ использовать ПРОГРАММУ на одном компьютере или сети одним пользователем. Если ПОЛЬЗОВАТЕЛЬ нацелен на использование ПРОГРАММЫ несколькими пользователями, то для каждого из пользователей должна быть приобретена отдельная лицензия. ПОЛЬЗОВАТЕЛЮ разрешается хранить одну резервную копию ЗАРЕГИСТРИРОВАННОЙ ПРОГРАММЫ.

РАСПРОСТРАНЕНИЕ НЕЗАРЕГИСТРИРОВАННОЙ КОПИИ

Неустановленная НЕЗАРЕГИСТРИРОВАННАЯ КОПИЯ может свободно копироваться и передаваться другим пользователям, при условии соблюдения ПОЛЬЗОВАТЕЛЕМ следующих требований. Если ПОЛЬЗОВАТЕЛЬ предлагает неустановленную НЕЗАРЕГИСТРИРОВАННУЮ КОПИЮ для загрузки, то он обязуется:

(1) Незамедлительно заменить неустановленную НЕЗАРЕГИСТРИРОВАННУЮ КОПИЮ новой версией ПРОГРАММЫ непосредственно после ее выпуска АВТОРОМ ;

(2) Немедленно удалить НЕЗАРЕГИСТРИРОВАННУЮ КОПИЮ по получении письменного или электронного уведомления от АВТОРА .

СРОК ДЕЙСТВИЯ ЛИЦЕНЗИИ

Данная ЛИЦЕНЗИЯ действительна до тех пор, пока ПОЛЬЗОВАТЕЛЬ использует ПРОГРАММУ и/или распространяет НЕЗАРЕГИСТРИРОВАННУЮ КОПИЮ в соответствии с порядком, устанавливаемым данным соглашением. В любом случае, ЛИЦЕНЗИЯ аннулируется в случае нарушения ПОЛЬЗОВАТЕЛЕМ условий данного ЛИЦЕНЗИОННОГО СОГЛАШЕНИЯ. По окончании ЛИЦЕНЗИИ ПОЛЬЗОВАТЕЛЬ обязуется удалить все копии ЗАРЕГИСТРИРОВАННОЙ и/или НЕЗАРЕГИСТРИРОВАННОЙ КОПИИ. Ограничения гарантии и ответственности, устанавливаемые дальнейшими разделами данного СОГЛАШЕНИЯ, остаются действующими и после истечения срока ЛИЦЕНЗИИ.

ПРИНЯТИЕ УСЛОВИЙ ДАННОГО СОГЛАШЕНИЯ

Факт загрузки и/или установки данной ПРОГРАММЫ означает принятие ПОЛЬЗОВАТЕЛЕМ условий данного СОГЛАШЕНИЯ.

ОГРАНИЧЕНИЯ ГАРАНТИИ

Программа поставляется "такой, какая она есть". АВТОР не гарантирует, что Программа не содержит ошибок. АВТОР не несет никакой ответственности за прямые или косвенные последствия применения или невозможности применения Программы, в том числе, за последствия, которые могут возникнуть из-за возможных ошибок в работе Программы.

АВТОР не несет никакой ответственности за потерю данных, прибыли, сбережений, а так же нарушение работы аппаратных средств, сетей и другие последствия или случайности, а также по претензиям, предъявляемым Вами на основании претензий третьей стороны.

ПРОЧИЕ ОГРАНИЧЕНИЯ

ПОЛЬЗОВАТЕЛЬ обязуется не распространять ПРОГРАММУ, т.е. не передавать ее для последующего использования третьим лицам. Под распространением ПРОГРАММЫ понимается тиражирование или предоставление доступа третьим лицам к воспроизведенным в любой форме компонентам ПРОГРАММЫ, в том числе сетевыми и иными способами, а также путем их продажи, проката, сдачи внаем или предоставления взаймы. Тиражированием не считается изготовление одной или нескольких резервных копий базы данных программы в целях обеспечения безопасности или архивации. Не дозволяется передача ЛИЦЕНЗИИ без специального на то разрешения АВТОРА.

ЕДИНОЕ СОГЛАШЕНИЕ

ЛИЦЕНЗИЯ является единым соглашением между АВТОРОМ и ПОЛЬЗОВАТЕЛЕМ, замещает все сторонние устные и письменные соглашения и не может быть изменена без специального письменного соглашения.


История версий

Версия 3.0.0

· Изменено оформление интерфейса
· Исправлено неправильное цветовое отображение результатов некоторых команд в окне вывода.
· Исправлена мелкая ошибка команды EXTRACT DDL.
· Добавлено два формата ведения журнала выполняемых команд (XML и таблица Oracle).
· Добавлен режим автоматической компиляции инвалидных объектов.
· Добавлен режим сохранения резервной копии PL/SQL объекта.

Версия 2.0.1

· Теперь выбранный тип файла в диалоге "Открыть" сохраняется и при последующем запуске программы.
· Подключена справка.

Версия 2.0.0

· Изменено оформление интерфейса.
· Исправлены мелкие ошибки.


Контакты

WWW: | http://dba.ucoz.ru
Email: | zhilin71@mail.ru


Интерфейс

Программа состоит из главного окна с набором различных функциональных вкладок:

· Скрипт – вкладка предназначена для загрузки, редактирования SQL команд и скриптов
· Вывод - служит для отображения эха и результатов выполняемых команд
· Изменяемые объекты - отображает объекты, которые переопределяются командами скрипта.
· Зависимые объекты - служит для отображения объектов, ссылающихся на изменяемые объекты
· Инвалидные объекты - показывает все объекты, которые приобрели инвалидный статус.


Инвалидные объекты

Вкладка служит для отображения объектов имеющих инвалидный статус, а также ошибок вызвавших переключение в это состояние. Вкладка состоит из трёх частей. Вверху вкладки расположена инструментальная панель. Она предназначена для быстрого обновления информации и осуществления компиляции инвалидных объектов. В середине вкладки расположен табличный элемент управления для отображения списка инвалидных объектов. Внизу вкладки расположен элемент управления для отображения текстовой информации об ошибках, возникших в PL/SQL объектах имеющих инвалидный статус.


Горячие клавиши

DBAScript for Oracle поддерживает следующие горячие клавиши:

· F5 , CTRL + ENTER - выполнить SQL команду
· CTRL + O - открыть файл


Выполнение скрипта

После того как скрипт загружен и проверен его можно запустить на выполнение. Для этого выберите пункт главного меню Скрипт | Выполнить или нажмите соответствующую кнопку на панели инструментов. Нажатие клавиши F5 также приведёт к выполнению скрипта.

В результате осуществленных действий на вкладке Вывод будет отображено эхо выполненных команд, результат выполнения и ошибки, если таковые имеются. Одновременно будет обновлена информация в статусной строке и на остальных вкладках. Дополнительно, в списке команд напротив каждой команды будет проставлен результат, соответствующий об успешности или не успешности её выполнения.

Если была включен режим автоматической компиляции инвалидных объектов, то сразу после выполнения скрипта без участия пользователя будет произведёно приведение этих объектов к нормальному статусу.

В случае включения режима резервного копирования PL/SQL объектов, перед выполнением скрипта происходит сохранение текущего кода выполняемого хранимого объекта в файл. Директория расположения файлов задаётся в настройках программы, на странице Скрипт.


Компиляция инвалидных объектов

На вкладке «Инвалидные объекты» имеется возможность восстановить нормальное состояние объектов с помощью перекомпиляции объекта. Сделать это можно с помощью инструментальной кнопки «Компилировать всё». Компиляция объектов происходит в отдельном потоке, в результате чего интерфейс программы не замораживается и в это время можно загружать или править другие скрипты. По окончании компиляции в самой правой панели статусной строки будет выдано сообщение об её завершении.

Можно досрочно прекратить выполнение компиляции объектов с помощью инструментальной кнопки «Прервать компиляцию», но выйти из программы до её окончания нельзя. В этом случае будет выдано предупреждающее сообщение.

Компилировать объекты можно несколькими способами. Выбор способа компиляции осуществляется с помощью выпадающего списка. Использование различных видов компиляции зависит от версии Oracle и типов инвалидных объектов и иногда дополняет друг друга.


Скрипт

Коневой каталог скриптов – этот параметр задаёт каталог, в который пользователь попадает при первой попытке загрузить скрипт.

Каталог резервного копирования – параметр указывает на каталог, в который будут сохраняться резервные копии PL/SQL объектов.


Отчёт

Вести отчёт о выполняемых командах – при включении этой опции начинается протоколирование выполнения команд.

Формат – параметр задает формат журнала протоколирования выполнения команд. Имеет три значения:

1. Текстовый - запись осуществляется в текстовый файл.
2. XML файл – запись осуществляется в файл XML формата.
3. Таблица – запись осуществляется в таблицу Oracle.

Имя – определяет имя файла или таблицы журнала. Имя можно набрать вручную или выбрать с помощью диалога, который вызывается при нажатии на кнопку, расположенную в правой части элемента управления.

Примечание:

При отсутствии файла журнала, он создаётся автоматически. При использовании в качестве журнала таблицы, она должна быть создана вручную заранее.

Записывать ошибки в файл – при включении это параметра осуществляется запись ошибок кода всех хранимых PL/SQL объектов в файл. Запись осуществляется после выполнения скрипта или при обновлении списка инвалидных объектов.


Безопасность

Сообщать при наличии среди изменяемых объектов – при включении этого параметра, в случае наличия какого либо критического объекта среди списка изменяемых объектов на экран выдается предупреждающее сообщение.

Сообщать при наличии среди зависимых объектов – при включении этого параметра, в случае наличия какого либо критического объекта среди списка зависимых объектов на экран выдается предупреждающее сообщение.

Объекты – вызвается диалоговая форма для изменения списка критических объектов.


Поддерживаемые команды SQLPlus

@file_name[.ext]

CONN[ECT] [username[/password] [@connect_identifier]] AS {SYSOPER|SYSDBA}

DEF[INE] [<имя переменной> = текст ]

DESC[RIBE] [schema.]object

Команда DESCRIBE позволяет получить описание таблицы или представления.
(На данный момент времени только для таблиц и представлений из dba_tab_columns и dba_col_comments)

DISC[ONNECT]

EXEC[UTE] statement

PASSW[ORD] [username]

PRO[MPT] [<текст>]

PRI[NT] [<имя переменной> <имя переменной>]

UNDE[FINE] [<имя переменной> <имя переменной>]

SET AUTOT[RACE] {ON|OFF|TRACE[ONLY]} [EXP[LAIN]] [STAT[ISTICS] [ALL]]

После выполнения операторов SELECT , INSERT , UPDATE или DELETE выводит отчет, в который может включаться план выполнения или статистическая информация о выполненных действиях. Опция ALL не присутствует в стандартной команде и позволяет выводить статистическую информацию не только для команд DML.

SET ECHO {ON|OFF }

Включает/Выключает отображение эха команды.

SET HEA[DING] {ON|OFF}

Включает / выключает отображение заголовков при выводе результата команды SELECT.

SET FEED[BACK] {ON|OFF}

Включает / выключает отображение вывода количества строк результата команды SELECT.

SET SERVEROUTPUT {ON|OFF} [SIZE n]

SET TI[ME] {ON|OFF}

SET TIMI[NG] {ON|OFF}

Включает / выключает отображение времени выполнения команды.

SHO[W] ERR[ORS] [{FUNCTION|PROCEDURE|PACKAGE|BODY|TRIGGER|VIEW|TYPE|TYPE BODY} [schema.]name]

SHO[W] PARAMETERS [parameter_name]

SHO[W] SGA [parameter_name]

SPO[OL] [file_name[.ext]|OFF|OUT]

VAR[IABLE ] [<имя переменной>] [<тип данных>] [= "значение"]

<тип данных> = CHAR|VARCHAR|VARCHAR2|NUMBER|CLOB

С помощью данной команды можно заранее задавать значение связываемой переменной. Данная возможность отсутствует в стандартной команде SqlPlus.

Пример:

VAR xVar VARCHAR2
VAR xVar="значение переменной"


Команды DBAScript

EXTR[ACT] DDL [{FUNCTION|PROCEDURE|PACKAGE [BODY]|TYPE}] [schema.]object [IN FILE <файл>]

Команда позволяет получить DDL команды для переопределения объекта и при необходимости вывести результат в файл. Если не задан тип объекта то ищется по имени первый объект из представления dba_source. Если файл существует то команда дописывает в файл.

LOB {READ|WRITE <имя переменной>}{|SAVE|LOAD <имя файла>}|CLEAR '<sql запрос>'

Команда позволяет читать значение столбца CLOB Sql запроса в переменную (файл) или записывать содержимое переменной (файла) в столбец Sql запроса. Переменная типа CLOB должна быть заранее объявлена с помощью команды VARIABLE. Для вывода значения переменной можно использовать команду PRINT. Опция CLEAR очищает содержимое CLOB поля.


Таблица журнала

Таблица журнала выполненных команд должна иметь примерно следующую структуру:

CREATE TABLE dbascript_log

(

timestamp DATE,

owner VARCHAR2 (30),

object_name VARCHAR2 (128),

command VARCHAR2 (61),

username VARCHAR2 (30),

filename VARCHAR2 (150)

)

/

COMMENT ON TABLE dbascript_log IS

'Протоколирование переопределения объектов'

/

COMMENT ON COLUMN dbascript_log.timestamp IS 'Время выполнения'

/

COMMENT ON COLUMN dbascript_log.owner IS 'Владелец объекта'

/

COMMENT ON COLUMN dbascript_log.object_name IS 'Имя объекта'

/

COMMENT ON COLUMN dbascript_log.command IS 'Команда'

/

COMMENT ON COLUMN dbascript_log.username IS 'Имя пользователя'

/

COMMENT ON COLUMN dbascript_log.filename IS 'Имя файла'

/